Compiler errors

Post here to report bugs in Warcraft3 XP. Please read the sticky.

Moderator: Forum Moderator

blake.403
Peon
Posts: 42
Joined: Sat Oct 15, 2005 7:00 pm
Contact:

Compiler errors

Postby blake.403 » Mon Oct 17, 2005 9:02 pm

Hi, im adding some code onto your wc3xp mod. Dont worry im not releasing it only using it for myself. But neways i keep getting this compilation error:

Welcome to the AMX Mod X 1.60-300 Compiler.
Copyright (c) 1997-2005 ITB CompuPhase, AMX Mod X Team

/home/users/amxmodx/tmp3/phpqVPGhg.sma(59) : fatal error 100: cannot read from file: "warcraft3.cfg"

Compilation aborted.
1 Error.
Could not locate output file /home/groups/amxmodx/public_html/websc3/phpqVPGhg.amx (compile failed).


That error is from the original unedited sma file that i got from here: http://www.amxmodx.org/forums/viewtopic.php?p=134006

I first got the error when i edited the sma file (was adding wc3_setxp) and i got the script after i asked for it from here:
http://www.amxmodx.org/forums/viewtopic.php?t=20402

So, im not sure if this is a compiler error (just with amxmodx.org's compiler) or if the file itself has a bug or w/e. Just thought i might let you know of this, as it may be something in the code or something.

BTW im in no way a coder, so im giving my best guess's on what could be wrong lol.

BTW: Im running wc3 v2.6.3 with amxx v1.60 and metamod v1.18

User avatar
Lazarus Long
Lead PITA SOB
Posts: 618
Joined: Tue Jul 05, 2005 9:24 pm

Postby Lazarus Long » Tue Oct 18, 2005 1:40 am

Download the files from here, and make sure the user you are running as has read rights over the warcraft3.cfg.
Lazarus

User avatar
ferret
Lead Warcraft 3 XP Developer
Posts: 422
Joined: Wed Jul 06, 2005 8:20 am
Location: Atlanta, GA
Contact:

Postby ferret » Tue Oct 18, 2005 6:42 am

Lazarus: I smell the AMXX web compiler.
-< www.gamehavoc.com >-

Lazarus Long: And I know you didn't because the Server Files are version 2.2.6 and the file you posted is version 2.2.5, so do as I told you above and don't ever lie to me again or help is gone!

blake.403
Peon
Posts: 42
Joined: Sat Oct 15, 2005 7:00 pm
Contact:

Postby blake.403 » Tue Oct 18, 2005 7:41 am

hmm lazarus what do you mean user im running has read rights over the warcraft3.cfg?

And ferret thats what i was thinking at first to heh. I'll try redoawnloading from lazarus's post (thx) and i'll update on u if theres a compiler prob. And if there is where can i find a compiler thats not off the amxx website?

Edit: I just tried recompiling the sma right from your link lazuras (vaul extended race, only copied the .sma file over) and i got the exact same error...

User avatar
ferret
Lead Warcraft 3 XP Developer
Posts: 422
Joined: Wed Jul 06, 2005 8:20 am
Location: Atlanta, GA
Contact:

Postby ferret » Tue Oct 18, 2005 8:24 am

I've never used the online compiler, but you'll have to provide it both the sma and the cfg, if it lets you. If not, it won't ever be able to compile it.
-< www.gamehavoc.com >-



Lazarus Long: And I know you didn't because the Server Files are version 2.2.6 and the file you posted is version 2.2.5, so do as I told you above and don't ever lie to me again or help is gone!

blake.403
Peon
Posts: 42
Joined: Sat Oct 15, 2005 7:00 pm
Contact:

Postby blake.403 » Tue Oct 18, 2005 9:53 am

hmm, i dont think it does as it only shows 1 possible upload slot and a script slot like this:

Screenshot

How should i compile this then? and how did you get it to compile?

Edit: Completely offtopic here lol, but ferret are you like the head guy for gamehavoc?! cause in your prof it says site operator. If so gj, im trying to get my own community going to heh. And the site is nice and easy to navigate.

User avatar
Geesu
<b>King of the world!</b>
Posts: 3158
Joined: Tue Jul 05, 2005 9:24 pm
Contact:

Postby Geesu » Tue Oct 18, 2005 10:23 am

You can't use the online web compiler...

unless you replace the #include "warcraft3.cfg" with whats in the config file.
No Support via PM

blake.403
Peon
Posts: 42
Joined: Sat Oct 15, 2005 7:00 pm
Contact:

Postby blake.403 » Tue Oct 18, 2005 11:07 am

hmm... well im new to scripting, i only added what i was told to add, is their a compiler i can download or something like that, that will allow me to compile this successfully?

User avatar
ferret
Lead Warcraft 3 XP Developer
Posts: 422
Joined: Wed Jul 06, 2005 8:20 am
Location: Atlanta, GA
Contact:

Postby ferret » Tue Oct 18, 2005 1:51 pm

Yes, I own and operate GameHavoc

blake, do this.

Open the SMA and the CFG

Find where it says this in the SMA and delete it: #include "warcraft3.cfg"
Copy and paste EVERYTHING from the CFG file and put it where that #include line was.

Save the SMA and try again.
-< www.gamehavoc.com >-



Lazarus Long: And I know you didn't because the Server Files are version 2.2.6 and the file you posted is version 2.2.5, so do as I told you above and don't ever lie to me again or help is gone!

User avatar
Lazarus Long
Lead PITA SOB
Posts: 618
Joined: Tue Jul 05, 2005 9:24 pm

Postby Lazarus Long » Tue Oct 18, 2005 5:17 pm

OK, guys, I must be off balance today, but why doesn't he just download AMX Mod X to his computer compile it localy and upload the warcraft3.amxx to his server? Did I miss something and he has to use the web compiler?
Lazarus


User avatar
ferret
Lead Warcraft 3 XP Developer
Posts: 422
Joined: Wed Jul 06, 2005 8:20 am
Location: Atlanta, GA
Contact:

Postby ferret » Tue Oct 18, 2005 5:33 pm

Because I'm too lazy to explain how and he already knows how the web compiler works.
-< www.gamehavoc.com >-



Lazarus Long: And I know you didn't because the Server Files are version 2.2.6 and the file you posted is version 2.2.5, so do as I told you above and don't ever lie to me again or help is gone!

blake.403
Peon
Posts: 42
Joined: Sat Oct 15, 2005 7:00 pm
Contact:

Postby blake.403 » Tue Oct 18, 2005 5:42 pm

heh im open to all suggestions, but im gonna try what you told me ferret, and also again gj on gamehavoc.com :wink:

Edit: Tried compiling got 26 errors :S maybe i did it wrong but heres the errors:

Welcome to the AMX Mod X 1.60-300 Compiler.
Copyright (c) 1997-2005 ITB CompuPhase, AMX Mod X Team

/home/users/amxmodx/tmp3/phpQNsmav.sma(1) : error 055: start of function body without function header
/home/users/amxmodx/tmp3/phpQNsmav.sma(52) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(54) : error 038: extra characters on line
/home/users/amxmodx/tmp3/phpQNsmav.sma(55) : error 038: extra characters on line
/home/users/amxmodx/tmp3/phpQNsmav.sma(56) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(61) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(63) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(110) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(139) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(144) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(146) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(154) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(160) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(167) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(169) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(175) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(185) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(192) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(196) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(200) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(203) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(208) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(211) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(214) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(223) : error 010: invalid function or declaration
/home/users/amxmodx/tmp3/phpQNsmav.sma(230) : error 010: invalid function or declaration

Compilation aborted.
26 Errors.
Could not locate output file /home/groups/amxmodx/public_html/websc3/phpQNsmav.amx (compile failed).


Heres the link to find my sma file:

http://rapidshare.de/files/6461118/warcraft3.sma.html

blake.403
Peon
Posts: 42
Joined: Sat Oct 15, 2005 7:00 pm
Contact:

Postby blake.403 » Wed Oct 19, 2005 3:06 am

Okay i know this is a DB, but im just posting that i finally have got my wc3xp sma file compiled. I had been asking for help on the amxmodx.org forums, and joka69 was able to help me out and he posted the sma/amxx. Just thought if you want this one comes with the wc3_setxp feature. Heres the link to the thread. Its got a file with this feature installed for WC3xp 2.6.3 shortterm, original races only (not compiled tho, and havent tested) WC3xp 2.6.3 longterm, vault, and i believe expanded races (both .sma and .amxx are there) and finally Warcraft3 XP 2.6.3 - Long term mode using VAULT, Expanded Races enabled, with starting level 2. I requested him to change the sma's startinglevels, because for somereason even thought my warcraft3.cfg said level2 it wasnt doing it, but now it works. Anyways just thought i might post all that here if anyone else wants it, or w/e. Thx for the support i got here.

Heres the link to the thread: http://www.amxmodx.org/forums/viewtopic.php?t=20484#


Return to “WC3XP - Bug Feedback”

Who is online

Users browsing this forum: No registered users and 1 guest