Help module not running

Read log files for errors! If this fails, come here for help

Moderator: Forum Moderator

Post Reply
miopalmo
Peon
Posts: 2
Joined: Mon Dec 12, 2005 12:14 pm

Help module not running

Post by miopalmo » Mon Dec 12, 2005 11:47 pm

Have the following problem War3FT does not run:
Latest version installled war3ft V 2.2.9

Metamod v1.18 2005/08/24 (5:12)
by Will Day <willday@metamod.org>
http://www.metamod.org/
compiled: Aug 23 2005, 22:36:41 +0200 (optimized)
This server is using AMX Mod X
Visit http://www.amxmod


] meta list
Currently loaded plugins:
description stat pend file vers src load unlod
[ 1] PODBOT RUN - podbot_mm.dll vR2b46d ini Chlvl ANY
[ 2] REALBOT RUN - realbot_mm.dll v3062 ini Chlvl ANY
[ 3] AMX Mod X RUN - amxmodx_mm.dll v1.60 ini ANY ANY
[ 4] BOTAIM2 RUN - botaim_mm.dll v2.3 ini ANY ANY
[ 5] Fun RUN - fun_amxx.dll v1.60 pl3 ANY ANY
[ 6] CStrike RUN - cstrike_amxx.dll v1.60 pl3 ANY ANY
[ 7] CSX RUN - csx_amxx.dll v1.60 pl3 ANY ANY
[ 8] War3ft RUN - war3ft_amxx.dll v2.2.5 pl3 ANY ANY
8 plugins, 8 running



] amxx version
AMX Mod X 1.60
Authors: Felix "SniperBeamer" Geyer, David "BAILOPAN" Anderson, Pavol "PM OnoTo" Marko, Jonny "Got His Gun" Bergstrom, and Lukasz "SidLuke" Wlasinski. (http://www.amxmodx.org)
Compiled: Sep 22 2005, 02:43:27
Core mode: JIT+

] amxx modules
Currently loaded modules:
name version author status
[ 1] Fun 1.60 AMX Mod X Dev Team running
[ 2] CStrike 1.60 AMX Mod X Dev Team running
[ 3] CSX 1.60 AMX Mod X Dev Team running
[ 4] War3ft 2.2.5 Geesu (Pimp Daddy) running
4 modules, 4 correct

] amxx plugins
Currently loaded plugins:
name version author file status
[ 1] Admin Base 1.60 AMXX Dev Team admin.amxx running
[ 2] Admin Commands 1.60 AMXX Dev Team admincmd.amxx running
[ 3] Admin Help 1.60 AMXX Dev Team adminhelp.amxx running
[ 4] Slots Reservation 1.60 AMXX Dev Team adminslots.amxx running
[ 5] Multi-Lingual Sys 1.60 AMXX Dev Team multilingual.am running
[ 6] Menus Front-End 1.60 AMXX Dev Team menufront.amxx running
[ 7] Commands Menu 1.60 AMXX Dev Team cmdmenu.amxx running
[ 8] Players Menu 1.60 AMXX Dev Team plmenu.amxx running
[ 9] Maps Menu 1.60 AMXX Dev Team mapsmenu.amxx running
[ 10] Admin Chat 1.60 AMXX Dev Team adminchat.amxx running
[ 11] Anti Flood 1.60 AMXX Dev Team antiflood.amxx running
[ 12] Scrolling Message 1.60 AMXX Dev Team scrollmsg.amxx running
[ 13] Info. Messages 1.60 AMXX Dev Team imessage.amxx running
[ 14] Admin Votes 1.60 AMXX Dev Team adminvote.amxx running
[ 15] NextMap 1.60 AMXX Dev Team nextmap.amxx running
[ 16] Nextmap Chooser 1.60 AMXX Dev Team mapchooser.amxx running
[ 17] TimeLeft 1.60 AMXX Dev Team timeleft.amxx running
[ 18] Pause Plugins 1.60 AMXX Dev Team pausecfg.amxx running
[ 19] Stats Configurati 1.60 AMXX Dev Team statscfg.amxx running
[ 20] Restrict Weapons 1.60 AMXX Dev Team restmenu.amxx running
[ 21] StatsX 1.60 AMXX Dev Team statsx.amxx running
[ 22] CS Misc. Stats 1.60 AMXX Dev Team miscstats.amxx running
[ 23] CS Stats Logging 1.60 AMXX Dev Team stats_logging.a running
[ 24] POD-Bot Menu 1.2 g4s|figurE.09 amxx_podbotmenu running
[ 25] unknown unknown unknown warcraft3FT.amx bad load
Load fails: Module "engine" required for plugin. Check module


_____plugins.ini metamod
;PODBOT
win32 addons/podbot/podbot_mm.dll PODBOT
;REALPLAYER
win32 ../realbot/dll/realbot_mm.dll REALBOT
; AMX Mod X
win32 addons/amxmodx/dlls/amxmodx_mm.dll
;BOTAIM2
win32 addons/botaim_plugin/Release/botaim_mm.dll BOTAIM2
_____


_____modules.ini ammx
; AMX Mod X Modules
; You can specify both linux & win32 modules here
; To enable a module, remove the semi-colon from the line

added
; warcraft
war3ft_amxx_i386.so
war3ft_amxx.dll

____

____plugins.ini amxx
added
warcraft3FT.amxx ;warcraft

____


Still modules seems not to load correctly and warft does not work.
Bots podbot and realbot work ok together.
What can I do?

User avatar
teame06
UWC3 Developer
Posts: 52
Joined: Fri Aug 26, 2005 4:15 pm

Post by teame06 » Tue Dec 13, 2005 1:51 am

[ 25] unknown unknown unknown warcraft3FT.amx bad load
Load fails: Module "engine" required for plugin. Check module
Hmmm... enable Engine

miopalmo
Peon
Posts: 2
Joined: Mon Dec 12, 2005 12:14 pm

Post by miopalmo » Tue Dec 13, 2005 2:36 am

hmmmmmmmmm
how do I do it?
Thanks

User avatar
GUNN3R17
Footman
Posts: 149
Joined: Wed Jul 06, 2005 5:24 pm
Location: Brea, CA
Contact:

Post by GUNN3R17 » Tue Dec 13, 2005 2:51 am

amxmodx/configs/modules.ini

remove the ";" thats infront of the engine...

erik2k3
Militia
Posts: 73
Joined: Wed Aug 03, 2005 6:34 am
Location: Germany / UK
Contact:

Post by erik2k3 » Tue Dec 13, 2005 11:31 am

yes, that would be it, but another question : realbot and podbot ? both on one server together ? that works ?
Image

User avatar
nightscream
Sorceress
Posts: 319
Joined: Wed Jul 06, 2005 12:54 pm
Location: Belguim, Hallaar
Contact:

Post by nightscream » Tue Dec 13, 2005 11:45 am

erik2k3 wrote:yes, that would be it, but another question : realbot and podbot ? both on one server together ? that works ?
yeah but there is a big chance of crashing so best way is not do it
want help pm me
Image

Post Reply